Scarlett MixControl tells me it's out of date with respect to the connected device

If you see the message "This version of Scarlett MixControl is out of date with respect to the connected device." when opening Scarlett MixControl on your Windows Computer, you'll need to install Scarlett MixControl 1.7.

We've temporarily removed this version from our main downloads pages due to an isolated issue with the firmware updater. Because you received this message your firmware is already up to date so you're not in danger of running into this issue. Please proceed to install Scarlett MixControl 1.7 from here:

Scarlett MixControl 1.7 for Windows

Once this is installed you should no longer see the error message when opening Scarlett MixControl.