Penta Troubleshooting Guide

No LEDs illuminate


• Is the POWER switched on?

• Is the correct mains voltage being used for your unit? If not, the fuse may blow, requiring the correct fuse to be refitted. (Click here to find the fuse rating for your unit.)

No output when using the MIC INPUT


• Is the power switched on?

• Is the MIC/INST switch on the front panel switched in?

• Is something connected to the Instrument input? (This overrides the mic input.)

• Is the LEVEL set correctly?

• For microphones that require phantom power, is the +48V switch engaged? (If you are unsure whether your microphone requires phantom power, check the user guide for your microphone.)

• Is the output lead connected to the left channel? (Right channel output doesn’t work when Mic/Inst is selected.)

No output when using the LINE INPUT


• Is the power switched on?

• Is the MIC/INST switch on the front panel switched out?

• Is the LEVEL set correctly?

No output when using the INSTRUMENT INPUT


• Is the power switched on?

• Is the MIC/INST switch on the front panel switched in?

• Is the LEVEL set correctly?

• Is the output lead connected to the left channel? (Right channel output doesn’t work when Mic/Inst is selected.)

The COMPRESSOR is not working


• Is the compressor section’s IN switch engaged?

• Is the LEVEL set correctly? If set too low, the signal level may not be high enough to activate the compressor.

• Is the COMPRESSION control set correctly? If set too low, the input level may not reach the threshold at which compression starts. (See user manual)

• Is there something connected to the compressor sidechain input?

No word clock lock


• Is your external word clock source transmitting word clock?

• Is the sample frequency set to match that of the word clock-transmitting device?

• Is an external word clock cable needed and, if so, is it connected? (See clocking regulations in the GENERIC SETUP)

No output from the digital output option


• Is the sample frequency set correctly?

• Is the receiving device set to receive at 24 bit?

• Is the receiving device set to external sync? (See DIGITAL in GENERIC SETUP)

• Is the signal format set correctly, Pro or Consumer, set with jumper J2? (See Platinum A/D card Jumpers section in GENERIC SETUP)